X-52 und Windows 7

Probleme oder Fragen zu LockOn. Tipps, Tricks, Anleitungen und Tutorials.

Moderator: JaBoG32 Stab

Wolke
Schaut öfter mal vorbei
Beiträge: 46
Registriert: 14. Dez 2006, 10:05

X-52 und Windows 7

Beitrag von Wolke » 6. Nov 2010, 15:01

Ich habe offenbar ein Problem mit dem X52 und Windows 7 (64bit-Version)

Der Joystick wird vom Windows erkannt und ich kann ihn auch benutzen. Problematisch wird es aber, wenn ich ein Profil lade. Dann spinnt der Joystick rum und reagiert nach einer Weile nicht mehr auf Knöpfe usw. Manchmal geht auch das Licht am Stick aus, manchmal geht eine Achse nicht mehr. Dann muß ich den USB-Stecker rausziehen, 1 Minute warten und wieder reinstecken. Dann funzt er wieder ein paar Minuten und stürzt dann erneut ab. Neueste Treiber hab ich.

Weiß da jemand von euch Rat ?

Laud
Professional
Beiträge: 6535
Registriert: 24. Nov 2003, 14:05

Re: X-52 und Windows 7

Beitrag von Laud » 6. Nov 2010, 15:23

Fürs erste würde mir nur eine Neu-Installation der SST und der Treiber einfallen.

Habe den X-52pro auch auf Win7/64, und da läuft alles ganz prima.

Acoran
Junior Member
Beiträge: 64
Registriert: 7. Feb 2007, 23:50

Re: X-52 und Windows 7

Beitrag von Acoran » 6. Nov 2010, 16:36

Wolke hat geschrieben: Manchmal geht auch das Licht am Stick aus


Ich hatte mal ein Kabelbruch im Verbindungskabel zwischen Throttle und Stick. Probleme mit einer Achse hatte ich da nicht aber einzelne Knöpfe haben dort auch nicht reagiert. Auch das der Stick komplett weg war (inklusive Licht) ist sehr oft vorgekommen. Sollte das jedoch wirklich nur vorkommen, wenn du ein Profil lädst wird es höchstwahrscheinlich nicht daran liegen.

Wolke
Schaut öfter mal vorbei
Beiträge: 46
Registriert: 14. Dez 2006, 10:05

Re: X-52 und Windows 7

Beitrag von Wolke » 6. Nov 2010, 18:45

Es passiert nur, wenn ich ein Profil lade. Und ich habe nur den X-52 (nicht den Pro). Könnte das eine Rolle spielen ??

Laud
Professional
Beiträge: 6535
Registriert: 24. Nov 2003, 14:05

Re: X-52 und Windows 7

Beitrag von Laud » 6. Nov 2010, 21:34

Ob pro oder nicht ist glaube ich bei deinem Problem nebensächlich.

Es könnte natürlich auch ein falsches/beschädigtes Profil-File sein.

Wolke
Schaut öfter mal vorbei
Beiträge: 46
Registriert: 14. Dez 2006, 10:05

Re: X-52 und Windows 7

Beitrag von Wolke » 7. Nov 2010, 08:51

Leider hat auch die Neuinstallation nichts gebracht. Die Profile werden samt und sonders fehlerhaft auf dem Display angezeigt und funzen auch nicht richtig. Auch ein Wechsel zwischen den Profilen bringt nichts.

Laud
Professional
Beiträge: 6535
Registriert: 24. Nov 2003, 14:05

Re: X-52 und Windows 7

Beitrag von Laud » 7. Nov 2010, 08:56

Hast du den Stick schonmal an einem anderen USB-Port getestet?

Wolke
Schaut öfter mal vorbei
Beiträge: 46
Registriert: 14. Dez 2006, 10:05

Re: X-52 und Windows 7

Beitrag von Wolke » 7. Nov 2010, 12:46

Ja, ich habe mir sogar einen USB-Hub mit Netzteil besorgt. Nutzt alles nix.

tekk1608
Gerade reingestolpert
Beiträge: 2
Registriert: 10. Nov 2010, 11:51

Re: X-52 und Windows 7

Beitrag von tekk1608 » 10. Nov 2010, 12:12

Hi,

ich habe ein ähnliches Problem. X52, Win7 mit 64Bit, SST und Treiber sind aktuell.
Hast du ein Dual/Quad-Core CPU? Sobald ich ein Profil lade und ich z.B. am Mode-Schalter drehe, geht auch schon auf dem Desktop(also nicht im Spiel) einer meinr beiden Kerne auf 100%(Im Taskmanger geht der System-Process auf 50%) und nach einiger Zeit geht bei mir auch das Display am X52 aus und Windows 7 meldet ein Problem bei einen USB-Gerät. Ab und anstecken lässt den 52 funktnieren bis ich wieder ein Profil lade. Da ich zunächst den X52 gar nicht verdächtig habe(mir ist erst aufgefallen, das ich manchmal 50% Systemlast hatte), habe mir mal mit MS-Diagnose-Tool genauer angeschaut, was genau die 50% verursacht. System-Process ist ja vieles. recht schnell habe ne SaiHDI.sys(oder so ähnlich) als Verursacher gefunden und darüber bin erst auf den X52 gekommen. Diese Datei ist wohl Teil der USB-Treiber für den X52.
Habe das letzten Freitag dem Support am Telefon erzählt, wobei die Dame am Telefon spätenes beim Wort Stacktrace aufgegeben hat und mich bat per Mail das nachmal zuschicken. Bisher habe keine Antwort und habe daher mal einige gegoogelt und dabei über diesen Thread gefunden und wollte mal hören ob es was neues gibt und meinen Infomationstand beitragen.

Gruß
Tekk

Laud
Professional
Beiträge: 6535
Registriert: 24. Nov 2003, 14:05

Re: X-52 und Windows 7

Beitrag von Laud » 10. Nov 2010, 15:22

Hallo und Willkommen tekk1608! Danke, dass du dich mit in das Thema eingeklinkt hast.

Nur um sicher zu gehen:

Ihr benutzt folgende Files:

- Saitek_X52_Flight_Controller_SD6_64.exe
- SST_Software_64_6_6_6_9.exe

oder?

Ansonsten registriert euch doch mal im Saitek Support Forum (englisch). Vielleicht können die euch helfen. Hier mal ein entfernt verwandter Thread dort: http://www.saitekforum.com/showthread.php?t=19415

Antworten